Run. Your. Business.
Call Us: 877.824.2524

Supported Browsers

Browsers

The NetQuarry platform fully supports the following tier 1 browsers:

The NetQuarry platform provides beta support for the following browsers:

  • None at this time.

The NetQuarry platform also supports the following older, tier 2 browsers:

  • Google Chrome 1.0 – 21.x (Windows/Mac)
  • Firefox 2.0 – 21.x (Windows), 3.0 – 21.x (Mac)
  • Internet Explorer 9.0 – 10.x well, 7.0 – 8.x OK, 6.x with 3rd party add-on help (Windows)
  • Safari 2.0 – 5.x (Mac), 3.0 – 5.x (Windows)
  • Opera 8.5 – 12.x (Windows), 9.01 – 12.x (Mac)

Other modern browsers can typically be expected to work well, but are not well tested and not officially supported. Other older browsers are not supported.

Regardless of browser type, the NetQuarry platform requires that cookies and javascript be enabled.